Gentoo Logo

Mailman: Directory traversal vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-11 / mailman
Release Date February 10, 2005
Latest Revision February 10, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-mail/mailman < 2.1.5-r4 >= 2.1.5-r4 All supported architectures

Related bugreports: #81109

Synopsis

Mailman fails to properly sanitize input, leading to information disclosure.

2.  Impact Information

Background

Mailman is a Python-based mailing list server with an extensive web interface.

Description

Mailman contains an error in private.py which fails to properly sanitize input paths.

Impact

An attacker could exploit this flaw to obtain arbitrary files on the web server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Mailman users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-mail/mailman-2.1.5-r4"

4.  References



Print

Page updated February 10, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.