Gentoo Logo

Perl: Vulnerabilities in perl-suid wrapper


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-13 / Perl
Release Date February 11, 2005
Latest Revision February 11, 2005: 01
Impact high
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/perl < 5.8.6-r3 >= 5.8.6-r3, revision >= 5.8.5-r4, revision >= 5.8.4-r3, revision >= 5.8.2-r3 All supported architectures

Related bugreports: #80460


Vulnerabilities leading to file overwriting and code execution with elevated privileges have been discovered in the perl-suid wrapper.

2.  Impact Information


Perl is a stable, cross-platform programming language created by Larry Wall. The perl-suid wrapper allows the use of setuid perl scripts, i.e. user-callable Perl scripts which have elevated privileges. This function is enabled only if you have the perlsuid USE flag set.


perl-suid scripts honor the PERLIO_DEBUG environment variable and write to that file with elevated privileges (CAN-2005-0155). Furthermore, calling a perl-suid script with a very long path while PERLIO_DEBUG is set could trigger a buffer overflow (CAN-2005-0156).


A local attacker could set the PERLIO_DEBUG environment variable and call existing perl-suid scripts, resulting in file overwriting and potentially the execution of arbitrary code with root privileges.

3.  Resolution Information


You are not vulnerable if you do not have the perlsuid USE flag set or do not use perl-suid scripts.


All Perl users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-lang/perl

4.  References


Page updated February 11, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.