Gentoo Logo

KStars: Buffer overflow in fliccd

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-23 / kstars
Release Date February 16, 2005
Latest Revision February 16, 2005: 01
Impact high
Exploitable remote and local
Package Vulnerable versions Unaffected versions Architecture(s)
kde-base/kdeedu < 3.3.2-r1 >= 3.3.2-r1 All supported architectures

Related bugreports: #79585

Synopsis

KStars is vulnerable to a buffer overflow that could lead to arbitrary code execution with elevated privileges.

2.  Impact Information

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like Operating Systems. KStars is a desktop planetarium for KDE. It includes support for the Instrument Neutral Distributed Interface (INDI).

Description

Erik Sjolund discovered a buffer overflow in fliccd which is part of the INDI support in KStars.

Impact

An attacker could exploit this vulnerability to execute code with elevated privileges. If fliccd does not run as daemon remote exploitation of this vulnerability is not possible. KDE as shipped by Gentoo does not start the daemon in the default installation.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All KStars users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=kde-base/kdeedu-3.3.2-r1"

4.  References



Print

Page updated February 16, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.