Gentoo Logo

Midnight Commander: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-24 / mc
Release Date February 17, 2005
Latest Revision February 17, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-misc/mc < 4.6.0-r13 >= 4.6.0-r13 All supported architectures

Related bugreports: #77992

Synopsis

Midnight Commander contains several format string errors, buffer overflows and one buffer underflow leading to execution of arbitrary code.

2.  Impact Information

Background

Midnight Commander is a visual console file manager.

Description

Midnight Commander contains several format string vulnerabilities (CAN-2004-1004), buffer overflows (CAN-2004-1005), a memory deallocation error (CAN-2004-1092) and a buffer underflow (CAN-2004-1176).

Impact

An attacker could exploit these vulnerabilities to execute arbitrary code with the permissions of the user running Midnight Commander or cause Denial of Service by freeing unallocated memory.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Midnight Commander users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-misc/mc-4.6.0-r13"

4.  References



Print

Page updated February 17, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.