Gentoo Logo

uim: Privilege escalation vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-31 / uim
Release Date February 28, 2005
Latest Revision February 28, 2005: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
app-i18n/uim < 0.4.5.1 >= 0.4.5.1 All supported architectures

Related bugreports: #82678

Synopsis

Under certain conditions, applications linked against uim suffer from a privilege escalation vulnerability.

2.  Impact Information

Background

uim is a simple, secure and flexible input method library.

Description

Takumi Asaki discovered that uim insufficiently checks environment variables. setuid/setgid applications linked against libuim could end up executing arbitrary code. This vulnerability only affects immodule-enabled Qt (if you build Qt 3.3.2 or later versions with USE="immqt" or USE="immqt-bc").

Impact

A malicious local user could exploit this vulnerability to execute arbitrary code with escalated privileges.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All uim users should upgrade to the latest available version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.5.1"

4.  References



Print

Page updated February 28, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.