Gentoo Logo

BidWatcher: Format string vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200503-06 / bidwatcher
Release Date March 03, 2005
Latest Revision March 03, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/bidwatcher < 1.3.17 >= 1.3.17 All supported architectures

Related bugreports: #82460

Synopsis

BidWatcher is vulnerable to a format string vulnerability, potentially allowing arbitrary code execution.

2.  Impact Information

Background

BidWatcher is a free auction tool for eBay users to keep track of their auctions.

Description

Ulf Harnhammar discovered a format string vulnerability in "netstuff.cpp".

Impact

Remote attackers can potentially exploit this vulnerability by sending specially crafted responses via an eBay HTTP server or a man-in-the-middle attack to execute arbitrary malicious code.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All BidWatcher users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/bidwatcher-1.13.17"

4.  References



Print

Page updated March 03, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.