Gentoo Logo

Axel: Vulnerability in HTTP redirection handling

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200504-09 / Axel
Release Date April 12, 2005
Latest Revision April 12, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/axel < 1.0b >= 1.0b All supported architectures

Related bugreports: #88264

Synopsis

A buffer overflow vulnerability has been found in Axel which could lead to the execution of arbitrary code.

2.  Impact Information

Background

Axel is a console-based FTP/HTTP download accelerator.

Description

A possible buffer overflow has been reported in the HTTP redirection handling code in conn.c.

Impact

A remote attacker could exploit this vulnerability by setting up a malicious site and enticing a user to connect to it. This could possibly lead to the execution of arbitrary code with the permissions of the user running Axel.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Axel users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/axel-1.0b"

4.  References



Print

Page updated April 12, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.