Gentoo Logo

Compress::Zlib: Buffer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200508-01 / Compress-Zlib
Release Date August 01, 2005
Latest Revision May 28, 2009: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
perl-core/Compress-Zlib < 1.35 >= 1.35 All supported architectures

Related bugreports: #100540

Synopsis

Compress::Zlib is vulnerable to a buffer overflow which could potentially lead to execution of arbitrary code.

2.  Impact Information

Background

The Compress::Zlib is a Perl module which provides an interface to the zlib compression library.

Description

Compress::Zlib 1.34 contains a local vulnerable version of zlib, which may lead to a buffer overflow.

Impact

By creating a specially crafted compressed data stream, attackers can overwrite data structures for applications that use Compress::Zlib, resulting in a Denial of Service and potentially arbitrary code execution.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Compress::Zlib users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=perl-core/Compress-Zlib-1.35"

4.  References



Print

Page updated August 01, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.