Gentoo Logo

Netpbm: Arbitrary code execution in pstopnm

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200508-04 / Netpbm
Release Date August 05, 2005
Latest Revision May 28, 2009: 06
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/netpbm < 10.28 >= 10.28, revision >= 10.26.32, revision >= 10.26.33, revision >= 10.26.42, revision >= 10.26.43, revision >= 10.26.44, revision >= 10.26.48, revision >= 10.26.49, revision >= 10.26.59, revision >= 10.26.61 All supported architectures

Related bugreports: #100398

Synopsis

The pstopnm utility, part of the Netpbm tools, contains a vulnerability which can potentially result in the execution of arbitrary code.

2.  Impact Information

Background

Netpbm is a package of 220 graphics programs and a programming libraries, including pstopnm. pstopnm is a tool which converts PostScript files to PNM image files.

Description

Max Vozeler reported that pstopnm calls the GhostScript interpreter on untrusted PostScript files without specifying the -dSAFER option, to convert a PostScript file into a PBM, PGM, or PNM file.

Impact

An attacker could craft a malicious PostScript file and entice a user to run pstopnm on it, resulting in the execution of arbitrary commands with the permissions of the user running pstopnm.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Netpbm users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose media-libs/netpbm

4.  References



Print

Page updated August 05, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.