Gentoo Logo

PHP: Vulnerabilities in included PCRE and XML-RPC libraries

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200509-19 / PHP
Release Date September 27, 2005
Latest Revision September 27, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-php/php < 4.4.0-r1 revision >= 4.3.11-r1, >= 4.4.0-r1 All supported architectures
dev-php/mod_php < 4.4.0-r2 revision >= 4.3.11-r1, >= 4.4.0-r2 All supported architectures
dev-php/php-cgi < 4.4.0-r2 revision >= 4.3.11-r2, >= 4.4.0-r2 All supported architectures

Related bugreports: #102373

Synopsis

PHP makes use of an affected PCRE library and ships with an affected XML-RPC library and is therefore potentially vulnerable to remote execution of arbitrary code.

2.  Impact Information

Background

PHP is a general-purpose scripting language widely used to develop web-based applications. It can run inside a web server using the mod_php module or the CGI version of PHP, or can run stand-alone in a CLI.

Description

PHP makes use of a private copy of libpcre which is subject to an integer overflow leading to a heap overflow (see GLSA 200508-17). It also ships with an XML-RPC library affected by a script injection vulnerability (see GLSA 200508-13).

Impact

An attacker could target a PHP-based web application that would use untrusted data as regular expressions, potentially resulting in the execution of arbitrary code. If web applications make use of the XML-RPC library shipped with PHP, they are also vulnerable to remote execution of arbitrary PHP code.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PHP users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-php/php

All mod_php users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-php/mod_php

All php-cgi users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-php/php-cgi

4.  References



Print

Page updated September 27, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.