Gentoo Logo

PHP: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200511-08 / PHP
Release Date November 13, 2005
Latest Revision November 13, 2005: 01
Impact normal
Exploitable remote and local
Package Vulnerable versions Unaffected versions Architecture(s)
dev-php/php < 4.4.0-r4 revision >= 4.3.11-r4, >= 4.4.0-r4 All supported architectures
dev-php/mod_php < 4.4.0-r8 revision >= 4.3.11-r4, >= 4.4.0-r8 All supported architectures
dev-php/php-cgi < 4.4.0-r5 revision >= 4.3.11-r5, >= 4.4.0-r5 All supported architectures

Related bugreports: #107602, #111032

Synopsis

PHP suffers from multiple issues, resulting in security functions bypass, local Denial of service, cross-site scripting or PHP variables overwrite.

2.  Impact Information

Background

PHP is a general-purpose scripting language widely used to develop web-based applications. It can run inside a web server using the mod_php module or the CGI version and also stand-alone in a CLI.

Description

Multiple vulnerabilities have been found and fixed in PHP:

  • a possible $GLOBALS variable overwrite problem through file upload handling, extract() and import_request_variables() (CVE-2005-3390)
  • a local Denial of Service through the use of the session.save_path option (CVE-2005-3319)
  • an issue with trailing slashes in allowed basedirs (CVE-2005-3054)
  • an issue with calling virtual() on Apache 2, allowing to bypass safe_mode and open_basedir restrictions (CVE-2005-3392)
  • a problem when a request was terminated due to memory_limit constraints during certain parse_str() calls (CVE-2005-3389)
  • The curl and gd modules allowed to bypass the safe mode open_basedir restrictions (CVE-2005-3391)
  • a cross-site scripting (XSS) vulnerability in phpinfo() (CVE-2005-3388)

Impact

Attackers could leverage these issues to exploit applications that are assumed to be secure through the use of proper register_globals, safe_mode or open_basedir parameters. Remote attackers could also conduct cross-site scripting attacks if a page calling phpinfo() was available. Finally, a local attacker could cause a local Denial of Service using malicious session.save_path options.

3.  Resolution Information

Workaround

There is no known workaround that would solve all issues at this time.

Resolution

All PHP users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-php/php

All mod_php users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-php/mod_php

All php-cgi users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-php/php-cgi

4.  References



Print

Page updated November 13, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.