Gentoo Logo

Lynx: Arbitrary command execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200511-09 / lynx
Release Date November 13, 2005
Latest Revision November 13, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-client/lynx < 2.8.5-r2 >= 2.8.5-r2 All supported architectures

Related bugreports: #112213

Synopsis

Lynx is vulnerable to an issue which allows the remote execution of arbitrary commands.

2.  Impact Information

Background

Lynx is a fully-featured WWW client for users running cursor-addressable, character-cell display devices such as vt100 terminals and terminal emulators.

Description

iDefense labs discovered a problem within the feature to execute local cgi-bin programs via the "lynxcgi:" URI handler. Due to a configuration error, the default settings allow websites to specify commands to run as the user running Lynx.

Impact

A remote attacker can entice a user to access a malicious HTTP server, causing Lynx to execute arbitrary commands.

3.  Resolution Information

Workaround

Disable "lynxcgi" links by specifying the following directive in lynx.cfg:

Code Listing 3.1: Workaround

TRUSTED_LYNXCGI:none

Resolution

All Lynx users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/lynx-2.8.5-r2"

4.  References



Print

Page updated November 13, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.