Gentoo Logo

Xpdf, GPdf, CUPS, Poppler: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200512-08 / xpdf, gpdf, poppler,cups
Release Date December 16, 2005
Latest Revision December 17, 2005: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-text/xpdf < 3.01-r2 >= 3.01-r2 All supported architectures
app-text/gpdf < 2.10.0-r2 >= 2.10.0-r2 All supported architectures
app-text/poppler < 0.4.2-r1 >= 0.4.2-r1, revision >= 0.3.0-r1 All supported architectures
net-print/cups < 1.1.23-r3 >= 1.1.23-r3 All supported architectures

Related bugreports: #114428, #115286

Synopsis

Multiple vulnerabilities have been discovered in Xpdf, GPdf, CUPS and Poppler potentially resulting in the execution of arbitrary code.

2.  Impact Information

Background

Xpdf and GPdf are PDF file viewers that run under the X Window System. Poppler is a PDF rendering library based on Xpdf code. The Common UNIX Printing System (CUPS) is a cross-platform print spooler. It makes use of Xpdf code to handle PDF files.

Description

infamous41md discovered that several Xpdf functions lack sufficient boundary checking, resulting in multiple exploitable buffer overflows.

Impact

An attacker could entice a user to open a specially-crafted PDF file which would trigger an overflow, potentially resulting in execution of arbitrary code with the rights of the user running Xpdf, CUPS, GPdf or Poppler.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r2"

All GPdf users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r2"

All Poppler users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose app-text/poppler

All CUPS users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-print/cups-1.1.23-r3"

4.  References



Print

Page updated December 16, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.