Gentoo Logo

Apache: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200602-03 / Apache
Release Date February 06, 2006
Latest Revision December 30, 2007: 03
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/apache < 2.0.55-r1 >= 2.0.55-r1, revision >= 2.0.54-r16, = 1.3.34-r2, revision >= 1.3.34-r11, revision >= 1.3.37 All supported architectures

Related bugreports: #115324, #118875


Apache can be exploited for cross-site scripting attacks and is vulnerable to a Denial of Service attack.

2.  Impact Information


The Apache HTTP server is one of the most popular web servers on the Internet. mod_imap provides support for server-side image maps; mod_ssl provides secure HTTP connections.


Apache's mod_imap fails to properly sanitize the "Referer" directive of imagemaps in some cases, leaving the HTTP Referer header unescaped. A flaw in mod_ssl can lead to a NULL pointer dereference if the site uses a custom "Error 400" document. These vulnerabilities were reported by Marc Cox and Hartmut Keil, respectively.


A remote attacker could exploit mod_imap to inject arbitrary HTML or JavaScript into a user's browser to gather sensitive information. Attackers could also cause a Denial of Service on hosts using the SSL module (Apache 2.0.x only).

3.  Resolution Information


There is no known workaround at this time.


All Apache users should upgrade to the latest version, depending on whether they still use the old configuration style (/etc/apache/conf/*.conf) or the new one (/etc/apache2/httpd.conf).

2.0.x users, new style config:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.55-r1"

2.0.x users, old style config:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=www-servers/apache-2.0.54-r16"

1.x users, new style config:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=www-servers/apache-1.3.34-r11"

1.x users, old style config:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=www-servers/apache-1.3.34-r2"

4.  References


Page updated February 06, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.