Gentoo Logo

Xpdf, Poppler: Heap overflow


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200602-04 / xpdf poppler
Release Date February 12, 2006
Latest Revision February 12, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-text/xpdf < 3.01-r7 >= 3.01-r7 All supported architectures
app-text/poppler < 0.5.0-r4 >= 0.5.0-r4 All supported architectures

Related bugreports: #120985


Xpdf and Poppler are vulnerable to a heap overflow that may be exploited to execute arbitrary code.

2.  Impact Information


Xpdf is a PDF file viewer that runs under the X Window System. Poppler is a PDF rendering library based on the Xpdf 3.0 code base.


Dirk Mueller has reported a vulnerability in Xpdf. It is caused by a missing boundary check in the splash rasterizer engine when handling PDF splash images with overly large dimensions.


By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.

3.  Resolution Information


There is no known workaround at this time.


All Xpdf users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r7"

All Poppler users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/poppler-0.5.0-r4"

4.  References


Page updated February 12, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.