Gentoo Logo

GnuPG: Integer overflow vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-08 / gnupg
Release Date August 05, 2006
Latest Revision August 08, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-crypt/gnupg < 1.4.5 >= 1.4.5 All supported architectures

Related bugreports: #142248


GnuPG is vulnerable to an integer overflow that could lead to the execution of arbitrary code.

2.  Impact Information


The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of cryptographic software.


Evgeny Legerov discovered a vulnerability in GnuPG that when certain packets are handled an integer overflow may occur.


By sending a specially crafted email to a user running an affected version of GnuPG, a remote attacker could possibly execute arbitrary code with the permissions of the user running GnuPG.

3.  Resolution Information


There is no known workaround at this time.


All GnuPG users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=app-crypt/gnupg-1.4*"

4.  References


Page updated August 05, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.