Gentoo Logo

Ruby on Rails: Several vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200608-20 / rails
Release Date August 14, 2006
Latest Revision December 13, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-ruby/rails < 1.1.6 >= 1.1.6 All supported architectures

Related bugreports: #143369

Synopsis

Ruby on Rails has some weaknesses potentially allowing a Denial of Service and maybe the remote execution of arbitrary Ruby scripts.

2.  Impact Information

Background

Ruby on Rails is an open-source web framework.

Description

The Ruby on Rails developers have corrected some weaknesses in action_controller/, relative to the handling of the user input and the LOAD_PATH variable. A remote attacker could inject arbitrary entries into the LOAD_PATH variable and alter the main Ruby on Rails process. The security hole has only been partly solved in version 1.1.5. Version 1.1.6 now fully corrects it.

Impact

A remote attacker that would exploit these weaknesses might cause a Denial of Service of the web framework and maybe inject arbitrary Ruby scripts.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Ruby on Rails users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-ruby/rails-1.1.6"

4.  References



Print

Page updated August 14, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.