Gentoo Logo

OpenTTD: Remote Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200609-03 / openttd
Release Date September 06, 2006
Latest Revision September 06, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
games-simulation/openttd < 0.4.8 >= 0.4.8 All supported architectures

Related bugreports: #131010

Synopsis

The OpenTTD server is vulnerable to a remote Denial of Service.

2.  Impact Information

Background

OpenTTD is a clone of Transport Tycoon Deluxe.

Description

OpenTTD is vulnerable to a Denial of Service attack due to a flaw in the manner the game server handles errors in command packets.

Impact

An authenticated attacker can cause a Denial of Service by sending an invalid error number to a vulnerable OpenTTD server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenTTD users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-simulation/openttd-0.4.8"

4.  References



Print

Page updated September 06, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.