Gentoo Logo

Adobe Flash Player: Arbitrary code execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200610-02 / Flash
Release Date October 04, 2006
Latest Revision May 28, 2009: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-plugins/adobe-flash < 7.0.68 >= 7.0.68 All supported architectures

Related bugreports: #147421

Synopsis

Multiple input validation errors have been identified that allow arbitrary code execution on a user's system via the handling of malicious Flash files.

2.  Impact Information

Background

The Adobe Flash Player is a renderer for Flash files - commonly used to provide interactive websites, digital experiences and mobile content.

Description

The Adobe Flash Player contains multiple unspecified vulnerabilities.

Impact

An attacker could entice a user to view a malicious Flash file and execute arbitrary code with the rights of the user running the player.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Adobe Flash Player users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-plugins/adobe-flash-7.0.68"

4.  References



Print

Page updated October 04, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.