Gentoo Logo

Qt: Integer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200611-02 / qt
Release Date November 06, 2006
Latest Revision January 09, 2009: 03
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
x11-libs/qt < 4.1.4-r2 >= 4.1.4-r2, revision >= 3.3.6-r4, revision >= 3.3.8, revision >= 3.3.8b All supported architectures

Related bugreports: #151838

Synopsis

An integer overflow flaw in the Qt pixmap handling could possibly lead to a Denial of Service or the remote execution of arbitrary code.

2.  Impact Information

Background

Qt is a cross-platform GUI toolkit, which is used e.g. by KDE.

Description

An integer overflow flaw has been found in the pixmap handling of Qt.

Impact

By enticing a user to open a specially crafted pixmap image in an application using Qt, e.g. Konqueror, a remote attacker could be able to cause an application crash or the execution of arbitrary code with the rights of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Qt 3.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/qt-3.3.6-r4"

All Qt 4.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/qt-4.1.4-r2"

4.  References



Print

Page updated November 06, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.