Gentoo Logo

OpenSSH: Multiple Denial of Service vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200611-06 / openssh
Release Date November 13, 2006
Latest Revision November 13, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/openssh < 4.4_p1-r5 >= 4.4_p1-r5 All supported architectures

Related bugreports: #149502

Synopsis

Several Denial of Service vulnerabilities have been identified in OpenSSH.

2.  Impact Information

Background

OpenSSH is a complete SSH protocol version 1.3, 1.5 and 2.0 implementation and includes sftp client and server support.

Description

Tavis Ormandy of the Google Security Team has discovered a pre-authentication vulnerability, causing sshd to spin until the login grace time has been expired. Mark Dowd found an unsafe signal handler that was vulnerable to a race condition. It has also been discovered that when GSSAPI authentication is enabled, GSSAPI will in certain cases incorrectly abort.

Impact

The pre-authentication and signal handler vulnerabilities can cause a Denial of Service in OpenSSH. The vulnerability in the GSSAPI authentication abort could be used to determine the validity of usernames on some platforms.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenSSH users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/openssh-4.4_p1-r5"

4.  References



Print

Page updated November 13, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.