Gentoo Logo

DenyHosts: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200701-01 / denyhosts
Release Date January 03, 2007
Latest Revision January 03, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/denyhosts < 2.6 >= 2.6 All supported architectures

Related bugreports: #157163

Synopsis

DenyHosts does not correctly parse log entries, potentially causing a remote Denial of Service.

2.  Impact Information

Background

DenyHosts is designed to monitor SSH servers for repeated failed login attempts.

Description

Tavis Ormandy of the Gentoo Linux Security Audit Team discovered that DenyHosts used an incomplete regular expression to parse failed login attempts.

Impact

A remote unauthenticated attacker can add arbitrary hosts to the blacklist by attempting to login with a specially crafted username. An attacker may use this to prevent legitimate users from accessing a host remotely.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All DenyHosts users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-admin/denyhosts-2.6"

4.  References



Print

Page updated January 03, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.