Gentoo Logo

Sun JDK/JRE: Execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200702-07 / java
Release Date February 17, 2007
Latest Revision July 16, 2008: 05
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-java/sun-jdk < 1.5.0.10, < 1.4.2.13 >= 1.5.0.10, revision >= 1.4.2.18, revision >= 1.4.2.17, revision >= 1.4.2.15, revision >= 1.4.2.14, revision >= 1.4.2.13 All supported architectures
dev-java/sun-jre-bin < 1.5.0.10, < 1.4.2.13 >= 1.5.0.10, revision >= 1.4.2.18, revision >= 1.4.2.17, revision >= 1.4.2.15, revision >= 1.4.2.14, revision >= 1.4.2.13 All supported architectures

Related bugreports: #162511

Synopsis

Sun Java Development Kit (JDK) and Java Runtime Environment (JRE) contain a memory corruption flaw that allows the applets to gain elevated privileges potentially leading to the execute of arbitrary code.

2.  Impact Information

Background

The Sun Java Development Kit (JDK) and the Sun Java Runtime Environment (JRE) provide the Sun Java platform.

Description

A anonymous researcher discovered that an error in the handling of a GIF image with a zero width field block leads to a memory corruption flaw.

Impact

An attacker could entice a user to run a specially crafted Java applet or application that would load a crafted GIF image, which could result in escalation of privileges and unauthorized access to system resources.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Sun Java Development Kit 1.5 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.5.0.10"

All Sun Java Development Kit 1.4 users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=dev-java/sun-jdk-1.4.2*"

All Sun Java Runtime Environment 1.5 users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.5.0.10"

All Sun Java Runtime Environment 1.4 users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose "=dev-java/sun-jre-bin-1.4.2*"

4.  References



Print

Page updated February 17, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.