Gentoo Logo Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200704-12 /
Release Date April 16, 2007
Latest Revision April 16, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-office/openoffice < 2.1.0-r1 >= 2.1.0-r1 All supported architectures
app-office/openoffice-bin < 2.2.0 >= 2.2.0 All supported architectures

Related bugreports: #170828


Multiple vulnerabilities have been discovered in, allowing for remote execution of arbitrary code.

2.  Impact Information

Background is an open source office productivity suite, including word processing, spreadsheet, presentation, drawing, data charting, formula editing, and file conversion facilities.


John Heasman of NGSSoftware has discovered a stack-based buffer overflow in the StarCalc parser and an input validation error when processing metacharacters in a link. Also OpenOffice.Org includes code from libwpd making it vulnerable to heap-based overflows when converting WordPerfect document tables (GLSA 200704-07).


A remote attacker could entice a user to open a specially crafted document, possibly leading to execution of arbitrary code with the rights of the user running

3.  Resolution Information


There is no known workaround at this time.


All users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/openoffice-2.1.0-r1"

All binary users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/openoffice-bin-2.2.0"

4.  References


Page updated April 16, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.