Gentoo Logo

Apache mod_perl: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200705-04 / mod_perl
Release Date May 02, 2007
Latest Revision May 02, 2007: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apache/mod_perl < 2.0.3-r1 >= 2.0.3-r1, revision >= 1.30 All supported architectures

Related bugreports: #172676

Synopsis

The mod_perl Apache module is vulnerable to a Denial of Service when processing regular expressions.

2.  Impact Information

Background

Mod_perl is an Apache module that embeds the Perl interpreter within the server, allowing Perl-based web-applications to be created.

Description

Alex Solvey discovered that the "path_info" variable used in file RegistryCooker.pm (mod_perl 2.x) or file PerlRun.pm (mod_perl 1.x), is not properly escaped before being processed.

Impact

A remote attacker could send a specially crafted URL to the vulnerable server, possibly resulting in a massive resource consumption.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All mod_perl 1.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apache/mod_perl-1.30"

All mod_perl 2.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apache/mod_perl-2.0.3-r1"

4.  References



Print

Page updated May 02, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.