Gentoo Logo

NX 2.1: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200710-09 / nx, nxnode
Release Date October 09, 2007
Latest Revision October 09, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/nx < 3.0.0 >= 3.0.0 All supported architectures
net-misc/nxnode < 3.0.0-r3 >= 3.0.0-r3 All supported architectures

Related bugreports: #192712

Synopsis

NX in the 2.1 series uses XFree86 4.3 code which is prone to an integer overflow vulnerability.

2.  Impact Information

Background

NoMachine's NX establishes remote connections to X11 desktops over small bandwidth links. NX and NX Node are the compression core libraries, whereas NX is used by FreeNX and NX Node by the binary-only NX servers.

Description

Chris Evans reported an integer overflow within the FreeType PCF font file parser (CVE-2006-1861). NX and NX Node are vulnerable to this due to shipping XFree86 4.3.0, which includes the vulnerable FreeType code.

Impact

A remote attacker could exploit these integer overflows by enticing a user to load a specially crafted PCF font file which might lead to the execution of arbitrary code with the privileges of the user on the machine running the NX server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All NX users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nx-3.0.0"

All NX Node users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.0.0-r3"

4.  References



Print

Page updated October 09, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.