Gentoo Logo

PDFKit, ImageKits: Buffer overflow


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200710-20 / pdfkit imagekits
Release Date October 18, 2007
Latest Revision October 18, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
gnustep-libs/pdfkit <= 0.9_pre062906 All supported architectures
gnustep-libs/imagekits <= 0.6 All supported architectures

Related bugreports: #188185


PDFKit and ImageKits are vulnerable to an integer overflow and a stack overflow allowing for the user-assisted execution of arbitrary code.

2.  Impact Information


PDFKit is a framework for rendering of PDF content in GNUstep applications. ImageKits is a collection of frameworks to support imaging in GNUstep applications.


Maurycy Prodeus discovered an integer overflow vulnerability possibly leading to a stack-based buffer overflow in the XPDF code which PDFKit is based on. ImageKits also contains a copy of PDFKit.


By enticing a user to view a specially crafted PDF file with a viewer based on ImageKits or PDFKit such as Gentoo's ViewPDF, a remote attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.

3.  Resolution Information


There is no known workaround at this time.


PDFKit and ImageKits are not maintained upstream, so the packages were masked in Portage. We recommend that users unmerge PDFKit and ImageKits:

Code Listing 3.1: Resolution

# emerge --unmerge gnustep-libs/pdfkit
# emerge --unmerge gnustep-libs/imagekits

As an alternative, users should upgrade their systems to use PopplerKit instead of PDFKit and Vindaloo instead of ViewPDF.

4.  References


Page updated October 18, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.