Gentoo Logo

Python: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200711-07 / python
Release Date November 07, 2007
Latest Revision November 07, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/python < 2.4.4-r6 revision >= 2.3.6-r3, >= 2.4.4-r6 All supported architectures

Related bugreports: #192876

Synopsis

Multiple integer overflow vulnerabilities have been discovered in Python, possibly resulting in the execution of arbitrary code or a Denial of Service.

2.  Impact Information

Background

Python is an interpreted, interactive, object-oriented programming language.

Description

Slythers Bro discovered multiple integer overflows in the imageop module, one of them in the tovideo() method, in various locations in files imageop.c, rbgimgmodule.c, and also in other files.

Impact

A remote attacker could entice a user to process specially crafted images with an application using the Python imageop module, resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service. Note that this vulnerability may or may not be exploitable, depending on the application using the module.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Python 2.3.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.3.6-r3"

All Python 2.4.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r6"

4.  References



Print

Page updated November 07, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.