Gentoo Logo

TikiWiki: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200711-19 / tikiwiki
Release Date November 14, 2007
Latest Revision November 14, 2007: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/tikiwiki < 1.9.8.3 >= 1.9.8.3 All supported architectures

Related bugreports: #195503

Synopsis

Multiple vulnerabilities have been discovered in TikiWiki, possibly resulting in the remote execution of arbitrary code.

2.  Impact Information

Background

TikiWiki is an open source content management system written in PHP.

Description

Stefan Esser reported that a previous vulnerability (CVE-2007-5423, GLSA 200710-21) was not properly fixed in TikiWiki 1.9.8.1 (CVE-2007-5682). The TikiWiki development team also added several checks to avoid file inclusion.

Impact

A remote attacker could exploit these vulnerabilities to inject arbitrary code with the privileges of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All TikiWiki users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-1.9.8.3"

4.  References



Print

Page updated November 14, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.