Gentoo Logo

GNU Emacs: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200712-03 / emacs
Release Date December 09, 2007
Latest Revision December 09, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-editors/emacs < 22.1-r3 >= 22.1-r3, revision >= 21.4-r14, < 19 All supported architectures

Related bugreports: #197958, #200297


Two vulnerabilities were found in GNU Emacs possibly leading to the execution of arbitrary code.

2.  Impact Information


GNU Emacs is a highly extensible and customizable text editor.


Drake Wilson reported that the hack-local-variables() function in GNU Emacs 22 does not properly match assignments of local variables in a file against a list of unsafe or risky variables, allowing to override them (CVE-2007-5795). Andreas Schwab (SUSE) discovered a stack-based buffer overflow in the format function when handling values with high precision (CVE-2007-6109).


Remote attackers could entice a user to open a specially crafted file in GNU Emacs, possibly leading to the execution of arbitrary Emacs Lisp code (via CVE-2007-5795) or arbitrary code (via CVE-2007-6109) with the privileges of the user running GNU Emacs.

3.  Resolution Information


The first vulnerability can be worked around by setting the "enable-local-variables" option to "nil", disabling the processing of local variable lists. GNU Emacs prior to version 22 is not affected by this vulnerability. There is no known workaround for the second vulnerability at this time.


All GNU Emacs users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-editors/emacs-22.1-r3"

4.  References


Page updated December 09, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.