Gentoo Logo

Mozilla Firefox, SeaMonkey: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200712-21 / firefox seamonkey
Release Date December 29, 2007
Latest Revision December 29, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-client/mozilla-firefox < 2.0.0.11 >= 2.0.0.11 All supported architectures
www-client/mozilla-firefox-bin < 2.0.0.11 >= 2.0.0.11 All supported architectures
www-client/seamonkey < 1.1.7 >= 1.1.7 All supported architectures
www-client/seamonkey-bin < 1.1.7 >= 1.1.7 All supported architectures

Related bugreports: #198965, #200909

Synopsis

Multiple vulnerabilities have been discovered in Mozilla Firefox and Mozilla Seamonkey.

2.  Impact Information

Background

Mozilla Firefox is a cross-platform web browser from Mozilla. SeaMonkey is a free, cross-platform Internet suite.

Description

Jesse Ruderman and Petko D. Petkov reported that the jar protocol handler in Mozilla Firefox and Seamonkey does not properly check MIME types (CVE-2007-5947). Gregory Fleischer reported that the window.location property can be used to generate a fake HTTP Referer (CVE-2007-5960). Multiple memory errors have also been reported (CVE-2007-5959).

Impact

A remote attacker could possibly exploit these vulnerabilities to execute arbitrary code in the context of the browser and conduct Cross-Site-Scripting or Cross-Site Request Forgery attacks.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-2.0.0.11"

All Mozilla Firefox binary users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-2.0.0.11"

All SeaMonkey users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-1.1.7"

All SeaMonkey binary users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-bin-1.1.7"

4.  References



Print

Page updated December 29, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.