Gentoo Logo

Opera: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200712-22 / opera
Release Date December 30, 2007
Latest Revision December 30, 2007: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-client/opera < 9.25 >= 9.25 All supported architectures

Related bugreports: #202770

Synopsis

Multiple vulnerabilities were discovered in Opera, allowing for the execution of arbitrary code and cross domain scripting.

2.  Impact Information

Background

Opera is a fast Web browser that is available free of charge.

Description

David Bloom reported two vulnerabilities where plug-ins (CVE-2007-6520) and Rich text editing (CVE-2007-6522) could be used to allow cross domain scripting. Alexander Klink (Cynops GmbH) discovered an issue with TLS certificates (CVE-2007-6521). Gynvael Coldwind reported that bitmaps might reveal random data from memory (CVE-2007-6524).

Impact

A remote attacker could exploit these vulnerabilities, possibly leading to the execution of arbitrary code and cross domain scripting.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Opera users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/opera-9.25"

4.  References



Print

Page updated December 30, 2007

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.