Gentoo Logo

Xfce: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200801-06 / xfce4-panel libxfcegui4
Release Date January 09, 2008
Latest Revision January 10, 2008: 03
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
xfce-base/xfce4-panel < 4.4.2 >= 4.4.2 All supported architectures
xfce-base/libxfcegui4 < 4.4.2 >= 4.4.2 All supported architectures

Related bugreports: #201292, #201293


Multiple vulnerabilities in Xfce might allow user-assisted attackers to execute arbitrary code.

2.  Impact Information


Xfce is a GTK+ 2 based desktop environment that allows to run a modern desktop environment on modest hardware.


Gregory Andersen reported that the Xfce4 panel does not correctly calculate memory boundaries, leading to a stack-based buffer overflow in the launcher_update_panel_entry() function (CVE-2007-6531). Daichi Kawahata reported libxfcegui4 did not copy provided values when creating "SessionClient" structs, possibly leading to access of freed memory areas (CVE-2007-6532).


A remote attacker could entice a user to install a specially crafted "rc" file to execute arbitrary code via long strings in the "Name" and "Comment" fields or via unspecified vectors involving the second vulnerability.

3.  Resolution Information


There is no known workaround at this time.


All Xfce4 panel users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=xfce-base/xfce4-panel-4.4.2"

All libxfcegui4 users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=xfce-base/libxfcegui4-4.4.2"

4.  References


Page updated January 09, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.