Gentoo Logo

NX: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200804-05 / nx, nxnode
Release Date April 06, 2008
Latest Revision April 06, 2008: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/nxnode < 3.1.0-r2 >= 3.1.0-r2 All supported architectures
net-misc/nx < 3.1.0-r1 >= 3.1.0-r1 All supported architectures

Related bugreports: #210317

Synopsis

NX uses code from the X.org X11 server which is prone to multiple vulnerabilities.

2.  Impact Information

Background

NoMachine's NX establishes remote connections to X11 desktops over small bandwidth links. NX and NX Node are the compression core libraries, whereas NX is used by FreeNX and NX Node by the binary-only NX servers.

Description

Multiple integer overflow and buffer overflow vulnerabilities have been discovered in the X.Org X server as shipped by NX and NX Node (vulnerabilities 1-4 in GLSA 200801-09).

Impact

A remote attacker could exploit these vulnerabilities via unspecified vectors, leading to the execution of arbitrary code with the privileges of the user on the machine running the NX server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All NX Node users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.1.0-r2"

All NX users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nx-3.1.0-r1"

4.  References



Print

Page updated April 06, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.