Gentoo Logo

Perl: Execution of arbitrary code


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200805-17 / perl libperl
Release Date May 20, 2008
Latest Revision May 20, 2008: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/perl < 5.8.8-r5 >= 5.8.8-r5 All supported architectures
sys-devel/libperl < 5.8.8-r2 >= 5.8.8-r2 All supported architectures

Related bugreports: #219203


A double free vulnerability was discovered in Perl, possibly resulting in the execution of arbitrary code and a Denial of Service.

2.  Impact Information


Perl is a stable, cross platform programming language.


Tavis Ormandy and Will Drewry of the Google Security Team have reported a double free vulnerability when processing a crafted regular expression containing UTF-8 characters.


A remote attacker could possibly exploit this vulnerability to execute arbitrary code or cause a Denial of Service.

3.  Resolution Information


There is no known workaround at this time.


All Perl users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/perl-5.8.8-r5"

All libperl users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-devel/libperl-5.8.8-r2"

4.  References


Page updated May 20, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.