Gentoo Logo

IBM JDK/JRE: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200806-11 / ibm-jdk-bin ibm-jre-bin
Release Date June 25, 2008
Latest Revision June 25, 2008: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-java/ibm-jdk-bin < 1.5.0.7 >= 1.5.0.7, revision >= 1.4.2.11 All supported architectures
dev-java/ibm-jre-bin < 1.5.0.7 >= 1.5.0.7, revision >= 1.4.2.11 All supported architectures

Related bugreports: #186277, #198644, #216112

Synopsis

Multiple vulnerabilities have been found in IBM Java Development Kit (JDK) and Java Runtime Environment (JRE), resulting in the execution of arbitrary code.

2.  Impact Information

Background

The IBM Java Development Kit (JDK) and the IBM Java Runtime Environment (JRE) provide the IBM Java platform.

Description

Because of sharing the same codebase, IBM JDK and JRE are affected by the vulnerabilities mentioned in GLSA 200804-20.

Impact

A remote attacker could entice a user to run a specially crafted applet on a website or start an application in Java Web Start to execute arbitrary code outside of the Java sandbox and of the Java security restrictions with the privileges of the user running Java. The attacker could also obtain sensitive information, create, modify, rename and read local files, execute local applications, establish connections in the local network, bypass the same origin policy, and cause a Denial of Service via multiple vectors.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All IBM JDK 1.5 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/ibm-jdk-bin-1.5.0.7"

All IBM JDK 1.4 users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/ibm-jdk-bin-1.4.2.11"

All IBM JRE 1.5 users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/ibm-jre-bin-1.5.0.7"

All IBM JRE 1.4 users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/ibm-jre-bin-1.4.2.11"

4.  References



Print

Page updated June 25, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.