Gentoo Logo

PCRE: Buffer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200807-03 / libpcre glib
Release Date July 07, 2008
Latest Revision July 07, 2008: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/libpcre < 7.7-r1 >= 7.7-r1 All supported architectures
dev-libs/glib < 2.16.3-r1 >= 2.16.3-r1, < 2.14.0 All supported architectures

Related bugreports: #228091, #230039

Synopsis

A buffer overflow vulnerability has been discovered in PCRE, allowing for the execution of arbitrary code and a Denial of Service.

2.  Impact Information

Background

PCRE is a Perl-compatible regular expression library. GLib includes a copy of PCRE.

Description

Tavis Ormandy of the Google Security team reported a heap-based buffer overflow when compiling regular expression patterns containing "Internal Option Settings" such as "(?i)".

Impact

A remote attacker could exploit this vulnerability by sending a specially crafted regular expression to an application making use of the PCRE library, which could possibly lead to the execution of arbitrary code or a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PCRE users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libpcre-7.7-r1"

All GLib users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/glib-2.16.3-r1"

4.  References



Print

Page updated July 07, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.