Gentoo Logo

NX: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200807-07 / nx, nxnode
Release Date July 09, 2008
Latest Revision July 09, 2008: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/nxnode < 3.2.0-r3 >= 3.2.0-r3 All supported architectures
net-misc/nx < 3.2.0-r2 >= 3.2.0-r2 All supported architectures

Related bugreports: #230147

Synopsis

NX uses code from the X.org X11 server which is prone to multiple vulnerabilities.

2.  Impact Information

Background

NoMachine's NX establishes remote connections to X11 desktops over small bandwidth links. NX and NX Node are the compression core libraries, whereas NX is used by FreeNX and NX Node by the binary-only NX servers.

Description

Multiple integer overflow and buffer overflow vulnerabilities have been discovered in the X.Org X server as shipped by NX and NX Node (GLSA 200806-07).

Impact

A remote attacker could exploit these vulnerabilities via unspecified vectors, leading to the execution of arbitrary code with the privileges of the user on the machine running the NX server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All NX Node users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.2.0-r3"

All NX users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nx-3.2.0-r2"

4.  References



Print

Page updated July 09, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.