Gentoo Logo

Python: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200807-16 / python
Release Date July 31, 2008
Latest Revision July 19, 2009: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/python < 2.5.2-r6 revision >= 2.4.4-r14, >= 2.5.2-r6, revision >= 2.4.6 All supported architectures

Related bugreports: #230640, #232137

Synopsis

Multiple vulnerabilities in Python may allow for the execution of arbitrary code.

2.  Impact Information

Background

Python is an interpreted, interactive, object-oriented programming language.

Description

Multiple vulnerabilities were discovered in Python:

  • David Remahl of Apple Product Security reported several integer overflows in core modules such as stringobject, unicodeobject, bufferobject, longobject, tupleobject, stropmodule, gcmodule, mmapmodule (CVE-2008-2315).
  • David Remahl of Apple Product Security also reported an integer overflow in the hashlib module, leading to unreliable cryptographic digest results (CVE-2008-2316).
  • Justin Ferguson reported multiple buffer overflows in unicode string processing that only affect 32bit systems (CVE-2008-3142).
  • The Google Security Team reported multiple integer overflows (CVE-2008-3143).
  • Justin Ferguson reported multiple integer underflows and overflows in the PyOS_vsnprintf() function, and an off-by-one error when passing zero-length strings, leading to memory corruption (CVE-2008-3144).

Impact

A remote attacker could exploit these vulnerabilities in Python applications or daemons that pass user-controlled input to vulnerable functions. Exploitation might lead to the execution of arbitrary code or a Denial of Service. Vulnerabilities within the hashlib might lead to weakened cryptographic protection of data integrity or authenticity.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Python 2.4 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r14"

All Python 2.5 users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.5.2-r6"

Please note that Python 2.3 is masked since June 24, and we will not be releasing updates to it. It will be removed from the tree in the near future.

4.  References



Print

Page updated July 31, 2008

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.