Gentoo Logo

Gnumeric: Untrusted search path

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200904-03 / gnumeric
Release Date April 03, 2009
Latest Revision April 03, 2009: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
app-office/gnumeric < 1.8.4-r1 >= 1.8.4-r1 All supported architectures

Related bugreports: #257012

Synopsis

An untrusted search path vulnerability in Gnumeric might result in the execution of arbitrary code.

2.  Impact Information

Background

The Gnumeric spreadsheet is a versatile application developed as part of the GNOME Office project.

Description

James Vega reported an untrusted search path vulnerability in the GObject Python interpreter wrapper in Gnumeric.

Impact

A local attacker could entice a user to run Gnumeric from a directory containing a specially crafted python module, resulting in the execution of arbitrary code with the privileges of the user running Gnumeric.

3.  Resolution Information

Workaround

Do not run "gnumeric" from untrusted working directories.

Resolution

All Gnumeric users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/gnumeric-1.8.4-r1"

4.  References



Print

Page updated April 03, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.