Gentoo Logo

Adobe products: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200908-04 / adobe-flash acroread
Release Date August 07, 2009
Latest Revision August 07, 2009: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-plugins/adobe-flash < 10.0.32.18 >= 10.0.32.18 All supported architectures
app-text/acroread < 9.1.3 >= 9.1.3 All supported architectures

Related bugreports: #278813, #278819

Synopsis

Multiple vulnerabilities in Adobe Reader and Adobe Flash Player allow for attacks including the remote execution of arbitrary code.

2.  Impact Information

Background

Adobe Flash Player is a closed-source playback software for Flash SWF files. Adobe Reader is a closed-source PDF reader that plays Flash content as well.

Description

Multiple vulnerabilities have been reported in Adobe Flash Player:

  • lakehu of Tencent Security Center reported an unspecified memory corruption vulnerability (CVE-2009-1862).
  • Mike Wroe reported an unspecified vulnerability, related to "privilege escalation" (CVE-2009-1863).
  • An anonymous researcher through iDefense reported an unspecified heap-based buffer overflow (CVE-2009-1864).
  • Chen Chen of Venustech reported an unspecified "null pointer vulnerability" (CVE-2009-1865).
  • Chen Chen of Venustech reported an unspecified stack-based buffer overflow (CVE-2009-1866).
  • Joran Benker reported that Adobe Flash Player facilitates "clickjacking" attacks (CVE-2009-1867).
  • Jun Mao of iDefense reported a heap-based buffer overflow, related to URL parsing (CVE-2009-1868).
  • Roee Hay of IBM Rational Application Security reported an unspecified integer overflow (CVE-2009-1869).
  • Gareth Heyes and Microsoft Vulnerability Research reported that the sandbox in Adobe Flash Player allows for information disclosure, when "SWFs are saved to the hard drive" (CVE-2009-1870).

Impact

A remote attacker could entice a user to open a specially crafted PDF file or web site containing Adobe Flash (SWF) contents, possibly resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service (application crash). Furthermore, a remote attacker could trick a user into clicking a button on a dialog by supplying a specially crafted SWF file and disclose sensitive information by exploiting a sandbox issue.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Adobe Flash Player users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-plugins/adobe-flash-10.0.32.18"

All Adobe Reader users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/acroread-9.1.3"

4.  References



Print

Page updated August 07, 2009

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.