Gentoo Logo

MaraDNS: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201202-03 / maradns
Release Date February 22, 2012
Latest Revision February 22, 2012: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-dns/maradns < 1.4.09 >= 1.4.09 All supported architectures

Related bugreports: #397431

Synopsis

A hash collision vulnerability in MaraDNS allows remote attackers to cause a Denial of Service condition.

2.  Impact Information

Background

MaraDNS is a proxy DNS server with permanent caching.

Description

MaraDNS does not properly randomize hash functions to protect against hash collision attacks.

Impact

A remote attacker could send many specially crafted DNS recursive queries, possibly resulting in a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All MaraDNS users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-dns/maradns-1.4.09"

4.  References



Print

Page updated February 22, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.