Gentoo Logo

libmikmod: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201203-10 / libmikmod
Release Date March 06, 2012
Latest Revision March 06, 2012: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libmikmod < 3.2.0_beta2-r3 >= 3.2.0_beta2-r3, revision >= 3.1.12-r1 All supported architectures

Related bugreports: #335892

Synopsis

Multiple buffer overflow vulnerabilities in libmikmod may allow an attacker to execute arbitrary code or cause a Denial of Service condition.

2.  Impact Information

Background

libmikmod is a library to play a wide range of module formats.

Description

Multiple boundary errors have been found in load_it.c in libmikmod, which may cause a buffer overflow.

Impact

A remote attacker could entice a user to open specially crafted files in an application linked against libmikmod, possibly resulting in execution of arbitrary code with the permissions of the user running the application, or Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All libmikmod 3.2 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=media-libs/libmikmod-3.2.0_beta2-r3"

All libmikmod 3.1 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libmikmod-3.1.12-r1"

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

4.  References



Print

Page updated March 06, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.