Gentoo Logo

OpenSSL: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201203-12 / openssl
Release Date March 06, 2012
Latest Revision July 07, 2014: 8
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/openssl < 1.0.0g >= 1.0.0g, revision >= 0.9.8t, revision >= 0.9.8u, revision >= 0.9.8v, revision >= 0.9.8w, revision >= 0.9.8x, revision >= 0.9.8y, revision >= 0.9.8z_p1, revision >= 0.9.8z_p2, revision >= 0.9.8z_p3, revision >= 0.9.8z_p4, revision >= 0.9.8z_p5 All supported architectures

Related bugreports: #397695, #399365

Synopsis

Multiple vulnerabilities have been found in OpenSSL, allowing remote attackers to cause a Denial of Service or obtain sensitive information.

2.  Impact Information

Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general purpose cryptography library.

Description

Multiple vulnerabilities have been found in OpenSSL:

  • Timing differences for decryption are exposed by CBC mode encryption in OpenSSL’s implementation of DTLS (CVE-2011-4108).
  • A policy check failure can result in a double-free error when X509_V_FLAG_POLICY_CHECK is set (CVE-2011-4109).
  • Clients and servers using SSL 3.0 handshakes do not clear the block cipher padding, allowing a record to contain up to 15 bytes of uninitialized memory, which could include sensitive information (CVE-2011-4576).
  • Assertion errors can occur during the handling of malformed X.509 certificates when OpenSSL is built with RFC 3779 support (CVE-2011-4577).
  • A resource management error can occur when OpenSSL’s server gated cryptography (SGC) does not properly handle handshake restarts (CVE-2011-4619).
  • Invalid parameters in the GOST block cipher are not properly handled by the GOST ENGINE(CVE-2012-0027).
  • An incorrect fix for CVE-2011-4108 creates an unspecified vulnerability for DTLS applications using OpenSSL (CVE-2012-0050).

Impact

A remote attacker may be able to cause a Denial of Service or obtain sensitive information, including plaintext passwords.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenSSL users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.0g"

4.  References



Print

Page updated March 06, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.