Gentoo Logo

Chromium, V8: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201205-04 / chromium v8
Release Date May 27, 2012
Latest Revision May 27, 2012: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-client/chromium < 19.0.1084.52 >= 19.0.1084.52 All supported architectures
dev-lang/v8 < 3.9.24.28 >= 3.9.24.28 All supported architectures

Related bugreports: #417321

Synopsis

Multiple vulnerabilities have been reported in Chromium and V8, some of which may allow execution of arbitrary code.

2.  Impact Information

Background

Chromium is an open source web browser project. V8 is Google’s open source JavaScript engine.

Description

Multiple vulnerabilities have been discovered in Chromium and V8. Please review the CVE identifiers and release notes referenced below for details.

Impact

A context-dependent attacker could entice a user to open a specially crafted web site or JavaScript program using Chromium or V8, possibly resulting in the execution of arbitrary code with the privileges of the process, or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Chromium users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=www-client/chromium-19.0.1084.52"

All V8 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/v8-3.9.24.28"

4.  References



Print

Page updated May 27, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.