Gentoo Logo

PHP: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201209-03 / php
Release Date September 24, 2012
Latest Revision September 24, 2012: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-lang/php < 5.3.15, < 5.4.5 >= 5.3.15, >= 5.4.5 All supported architectures

Related bugreports: #384301, #396311, #396533, #399247, #399567, #399573, #401997, #410957, #414553, #421489, #427354, #429630


Multiple vulnerabilities were found in PHP, the worst of which lead to remote execution of arbitrary code.

2.  Impact Information


PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.


Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.


A remote attacker could execute arbitrary code with the privileges of the process, cause a Denial of Service condition, obtain sensitive information, create arbitrary files, conduct directory traversal attacks, bypass protection mechanisms, or perform further attacks with unspecified impact.

3.  Resolution Information


There is no known workaround at this time.


All PHP users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-5.3.15"

All PHP users on ARM should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.5"

4.  References


Page updated September 24, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.