Gentoo Logo

qemu-kvm: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201210-04 / ebuild
Release Date October 18, 2012
Latest Revision October 18, 2012: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-emulation/qemu-kvm < 1.1.1-r1 >= 1.1.1-r1 All supported architectures

Related bugreports: #364889, #365259, #372411, #373997, #400595, #430456

Synopsis

Multiple vulnerabilities were found in qemu-kvm, allowing attackers to execute arbitrary code.

2.  Impact Information

Background

qemu-kvm provides QEMU and Kernel-based Virtual Machine userland tools.

Description

Multiple vulnerabilities have been discovered in qemu-kvm. Please review the CVE identifiers referenced below for details.

Impact

These vulnerabilities allow a remote attacker to cause a Denial of Service condition on the host server or qemu process, might allow for arbitrary code execution or a symlink attack when qemu-kvm is in snapshot mode.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All qemu-kvm users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulation/qemu-kvm-1.1.1-r1"

4.  References



Print

Page updated October 18, 2012

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.