Gentoo Logo

Xen: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201309-24 / xen
Release Date September 27, 2013
Latest Revision September 27, 2013: 1
Impact high
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
app-emulation/xen < 4.2.2-r1 >= 4.2.2-r1 All supported architectures
app-emulation/xen-tools < 4.2.2-r3 >= 4.2.2-r3 All supported architectures
app-emulation/xen-pvgrub < 4.2.2-r1 >= 4.2.2-r1 All supported architectures

Related bugreports: #385319, #386371, #420875, #431156, #454314, #464724, #472214, #482860

Synopsis

Multiple vulnerabilities have been found in Xen, allowing attackers on a Xen Virtual Machine to execute arbitrary code, cause Denial of Service, or gain access to data on the host.

2.  Impact Information

Background

Xen is a bare-metal hypervisor.

Description

Multiple vulnerabilities have been discovered in Xen. Please review the CVE identifiers referenced below for details.

Impact

Guest domains could possibly gain privileges, execute arbitrary code, or cause a Denial of Service on the host domain (Dom0). Additionally, guest domains could gain information about other virtual machines running on the same host or read arbitrary files on the host.

3.  Resolution Information

Workaround

The CVEs listed below do not currently have fixes, but only apply to Xen setups which have “tmem” specified on the hypervisor command line. TMEM is not currently supported for use in production systems, and administrators using tmem should disable it. Relevant CVEs: * CVE-2012-2497 * CVE-2012-6030 * CVE-2012-6031 * CVE-2012-6032 * CVE-2012-6033 * CVE-2012-6034 * CVE-2012-6035 * CVE-2012-6036

Resolution

All Xen users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulation/xen-4.2.2-r1"

All Xen-tools users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=app-emulation/xen-tools-4.2.2-r3"

All Xen-pvgrub users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=app-emulation/xen-pvgrub-4.2.2-r1"

4.  References



Print

Page updated September 27, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.