Gentoo Logo

LibYAML: Arbitrary code execution


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201403-02 / libyaml
Release Date March 08, 2014
Latest Revision March 08, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/libyaml < 0.1.5 >= 0.1.5 All supported architectures

Related bugreports: #499920


A Vulnerability in LibYAML could result in execution of arbitrary code.

2.  Impact Information


LibYAML is a YAML 1.1 parser and emitter written in C.


A heap-based buffer overflow flaw was found in the way libyaml parsed YAML tags.


A remote attacker could provide a specially-crafted YAML document which when parsed by LibYAML, would cause the application to crash or, potentially, execute arbitrary code with the privileges the user who is running the application.

3.  Resolution Information


There is no known workaround at this time.


All LibYAML users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libyaml-0.1.5"

4.  References


Page updated March 08, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.