Gentoo Logo

Asterisk: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-05 / asterisk
Release Date May 03, 2014
Latest Revision May 03, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/asterisk < 11.8.1 >= 11.8.1, revision >= 1.8.26.1 All supported architectures

Related bugreports: #504180

Synopsis

Multiple buffer overflows in Asterisk might allow remote attackers to cause a Denial of Service condition.

2.  Impact Information

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers and Asterisk Project Security Advisories referenced below for details.

Impact

A remote attacker could possibly cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Asterisk 11.* users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.8.1"

All Asterisk 1.8.* users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.26.1"

4.  References



Print

Page updated May 03, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.